I've been trying to paint onto a mesh I created, and I was able to paint onto it yesterday with no issues. I had to resculpt some details with dynotopo and redo the UVs so now I'm repainting it, however I have an issue. No matter the brush or settings, the color of the brush is always black, not the texture itself, but the brush. I'm trying to create a subdermal texture for a hand


  • 1
    $\begingroup$ Need a screenshot of just the cycles node tree so we can see how everything is arranged - you seem to have two materials going on and in material draw mode, so maybe your previous material is combining with your current selected material...if you add a new material and paint ot a blank white image, do you get the normal color you expect or do you still get your darker version? $\endgroup$ Mar 21 '17 at 2:23

Try delete brush and create new. That worked to me.

enter image description here

  • 2
    $\begingroup$ please don't make the text of the answer part of the images. Not only is the text not editable, but search engines cannot read it, making your answer less useful and the information in it harder to find. $\endgroup$
    – user1853
    May 21 '17 at 16:51

There can be two reasons.

  1. The first is black texture in the stencil slot.
  2. The second is the absence of a light source on the stage (in Cycles, Shadeless Mode does not always work).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.