3
$\begingroup$

I have created a model of a mandrill and I’ve been using particles to make the fur. Because the fur throughout the body of a mandrill is very different, I’m duplicating parts of the whole mesh and slightly scaling them down to stay inside the big mesh. So I have a “chin" mesh with one particle system, a "face/top head" mesh with another particle system, etc. I guess I could use vertex groups for the same purpose, but several tutorials seem to use the duplicated-mesh-parts approach to keep the flexibility of retouching the whole mesh if necessary.

On some of the particle systems - e.g. the chin - I’m getting the result I’m after. On others - e.g. face/top head - even though the particles look fine upon creation, once I comb and render, they get a life of their own and point to different directions, clump, etc.

I have recalculated the normals, checked deflect emitter and even tried applying the particle systems to vertex groups created in the whole mesh (rather than using the duplicated parts). But I’m still getting a very sad looking mandrill.

Any ideas? Thank you.

$\endgroup$
  • 1
    $\begingroup$ Particle problem can be hard to solve without knowing the specific settings. I highly recommend that you could upload the problematic scene, e.g. you can upload it here. $\endgroup$ – Leon Cheung Mar 5 '14 at 17:19
  • $\begingroup$ You may check whether the hair dynamics is enabled, or whether set an initial velocity, or whether have it influenced by other force field in the scene. $\endgroup$ – Leon Cheung Mar 5 '14 at 17:25
  • $\begingroup$ Thank you very much Leon. I uploaded the file here. Hair dynamics is not enabled and I don't seem to detect an initial velocity or other forces; but I'm also learning as I'm going, so your opinion is appreciated $\endgroup$ – user2694 Mar 5 '14 at 18:58
  • $\begingroup$ Looks fine for me.. Could you add some screenshots highlighting the issue? $\endgroup$ – gandalf3 Mar 5 '14 at 20:39
  • $\begingroup$ In this folder you'll find two renders, one before and another after combing. The combing I did was simple, just pushing the particles to the back, but they all went in different directions, as you can see. I'm not able to shape the fur as I want, as a mandrill would look like. $\endgroup$ – user2694 Mar 5 '14 at 22:24
1
$\begingroup$

When setting up particle hair we normally configure a small number of hairs, then use children hairs that get created around each existing hair to fill out for the render.

The children hair settings have options that make them curl up or clump together around the parent hair. I think the bending and clumping you see is the children hairs being deformed by these settings after they are shown. Most likely this is because in particle edit mode you aren't showing any children, so when they show up in object mode they look much different. While in particle edit mode you can turn on the option to display children hairs. This is in the toolbar T under Options.

enter image description here

For performance we normally only display a portion of the children hairs while grooming the hair, and use more hairs for a better final image. These options are found in the Children panel of the particle settings. Display is how many children we see in the 3dview, while Render is how many are used at final render stage. If you set these the same while grooming the hair you will see less change at render time. Once finished grooming you may want to turn Display back down to keep the 3dview responding.

enter image description here

$\endgroup$
  • $\begingroup$ Thank you very much sampler. Actually the difference I'm seeing is not before and after visualizing the children. It's before and after combing. This folder contains two renders, before and after combing. What I don't understand is why the combing process makes the hairs go in all different directions rather than arranging them according to my comb strokes. Thank you. $\endgroup$ – user2694 Mar 6 '14 at 23:18
0
$\begingroup$

Check to make sure that the setting for your modifiers are the same for view and render. If, for example, you have a subsurf modifier set at 1 for view and 3 for render, it will throw your hair wild. You probably want to keep the render value the same, but if you set your subsurf view option to 3, it will slow down your machine. I'm trying to figure out now how I will work with a high-res mesh and a low-res mesh with the high res set to invisible. I know this is doable, but it introduces some complexities.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.