0
$\begingroup$

I have an IK chain, and there are some axes that I don't want some bones to rotate around. So I go to the bone tab, scroll down to Inverse Kinematics, and lock the axes I don't want the bone to rotate on. All well and good.

Now I have created three of these IK chains and arranged them in a triangle (separated by 120 degrees). One works great because it was aligned with the axes, but the other two are not, and therefore, rotate incorrectly due to the locking appearing to be in the world space.

Just to double check, I have tried adding bone constraints to lock specific axes, but due to the IK, these have no effect.

How can I lock the IK rotation of a bone on specific axes in the bone's local space?

$\endgroup$
0
$\begingroup$

In fact, the rotation locks are applied to the local axes. As long as the bone is oriented correctly, you will get the correct results. When creating multiple copies and rotating, you must make sure to adjust the roll of the bone (in Edit Mode) in the Bone properties tab to the correct direction.

To confirm the orientation of the bones, you can go to the Armature properties tab, and under Display, check Axes. Now when you look at your bones, the tip of it will display the directions. Keep in mind that the axes will display at the tip, so don't get confused by another bone connected to the base as it only applies to that bone.

From there, you can choose your IK locking settings for the bone according to what the bone's display shows.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.