0
$\begingroup$

I created a character mesh using the manuel bastioni, and then wanted to use the rig created by rigify. I followed the steps as in this video: https://www.youtube.com/watch?v=dYiAd_08-0k

When I parent the character mesh to the rig, there are a bunch of vertex groups created. But, when I click on any of them and click "select" in edit mode, no vertices are selected. This also means that the rig is not really skinned - no vertex moves along with the rig. I have looked online for other's having a similar issue, and none of those apply to this case (for e.g., scale transform is applied before parenting).

Here is a google drive to the blend file, saved right after I did the parenting. The metarig is present but hidden, in case you want try regenerating the rigify rig. What is going wrong?

My .blend file can be found Here

$\endgroup$
  • $\begingroup$ I retraced my steps with a mesh created in makehuman, and the this is not a problem. I am not sure what is different about the mesh created with manuel bastioni mesh that this is not working. $\endgroup$ – Aman Mar 12 '17 at 5:42
0
$\begingroup$

It's not you, it is the ManuelBastioniLAB generated mesh that is an issue.

I haven't dug into how it works yet but the mesh from the LAB is generated and controlled even if the addon is disabled. If you select the mesh and go into edit mode you will find that you can't move any vertices but if you add or duplicate a vertex you can start editing with it all going back to how it was after you exit edit mode.

In the object properties, if you change the parent type from object to armature you can deform the mesh with the rigify armature but it won't look good.

There is a skeleton included with the generated model, if you keep that armature you can pose your character. This rig is a basic one without extras like IK. Maybe this can be improved or a rigify rig could be attached to this rig as a controller.

$\endgroup$
  • $\begingroup$ Thanks for this post. I really liked Manuel Bastioni characters, especially the anime ones, but wanted to add IK. $\endgroup$ – Aman Mar 12 '17 at 19:13
1
$\begingroup$

Hey I just got the same problem with the ManuelBastioniLAB Addon and what seems to work for me is the following:

So do you remember that you have to check your mesh, that had to be only close mesh with no additional objects like the eye balls and teeth... well after i spitted and isolated the body I deleted the double vertex by getting to edit mode, select all the vertices, press W+Remove double vertex BUT changing the "merge distance" to 0.0400 or any slightly higher value instead of the default one, for some reason double vertices used for the edge split to fix edges normals on a smooth surface are not as close as they have for the default "delete double vertex" function to do the job.

Hope that works for you! It took me a long time to find out!

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.