1
$\begingroup$

My bones with the inverse kinematics applied just don't rotate/translate properly:

knee not moving properly

I would like them to stick together at the knee with the knee bending accordingly. Also if I set the higher leg as a parent I have this result:

enter image description here

I also tried to connect them with ctrl+p in edit mode but nothing changed. I know that if I make the bones from scratch extruding from the tip of the bones I would probably solve the problem but I want to understand this behaviour.

$\endgroup$
1
  • $\begingroup$ It seems that your character's mesh is not parented to the armature or it does not have vertex weights to be influenced by bones movements. Try in object mode: select the character, shift select active the armature, then ctrl+P and choose 'with automatic weights'. The result may be 'bad' but that may allow the check if you still have the issue. $\endgroup$
    – lemon
    Commented Mar 12, 2017 at 6:33

1 Answer 1

0
$\begingroup$

To connect the bones you can reparent the bone in edit mode and make sure that you select connected rather that keep offset. You can also set this in the relations section of the bone's properties, it is a checkbox labelled connected.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .