1
$\begingroup$

I have a texture added to some planes (cube with four sides deleted) and there's an odd problem. some of the planes seems to have the texture on the wrong side of the normal and catch the light in a different way as you can see in this image enter image description here on the left side of image everything looks right all walls catch the light in the same way but on the right side the wall won't show the light on it unless I flip the normal so the normal points to the inside they are built with a copy of the same block and all of the normals point in the same direction.
is it possible to apply the same material inside out to another object?

$\endgroup$
3
  • 1
    $\begingroup$ I don't think this has anything to do with materials or textures themselves, solving it through the material maybe hiding the real problem. There is probably something wrong with the geometry itself. Please edit your question and provide more details like wireframe and edit mode of your mesh, modifier stack, normals, materials setup etc. May be an object with negative scale, or something else, its impossible to know from the provided information alone. $\endgroup$ Mar 10, 2017 at 19:05
  • $\begingroup$ maybe try an hdri? i remember when i had a problem similar to this, i added an hdri and it fixed my problem. hope i helped :) $\endgroup$ May 18, 2017 at 23:00
  • $\begingroup$ If the object is constructed from only one sided planes (no thickness added e.g. with Solidify) then no way to make textures look the same, normals will always point in different direction because face can have only one normal vector. There's Double Sided option in the Object Data tab but it's resources heavy. Try either applying Solidify or changing the object design. $\endgroup$
    – Mr Zak
    Nov 27, 2017 at 13:42

3 Answers 3

1
$\begingroup$

looks like I forgot to mark this one as solved, to solution was choosing non color data for normal image in material / node editor

$\endgroup$
0
$\begingroup$

Make sure you have all your normals lined up correctly by going into edit mode, clicking on the recalculate normals button and then checking back in.

$\endgroup$
0
$\begingroup$

This is the problem of normals I think you need to recalculate it and flip the normal if needed. Just tap t on your window to open your tools tab if you don't have it opened and then Click on relation tab in object tools and click recalculate and remember to be in edit mode and also select every thing in edit mode by taping A key.

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .