I'm working on a cylinder with 8 sections and when I have worked on other shapes before my materials have rendered fine, but with the cylinder as I click render my materials have disappeared or one has been pasted over each section shape.

There might just be a simple solution I'm missing, but I need help fast! much appreciated if anyone can thanks!

examples of what I mean:

Editing Stage:

enter image description here

Rendered Image:

enter image description here


closed as off-topic by iKlsR Apr 4 '14 at 17:07

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This question is too localized in its current form and is unlikely to be applicable outside of a very narrow context. Consider broadening the scope of this question in order to make it more useful for future users of the site." – iKlsR
If this question can be reworded to fit the rules in the help center, please edit the question.

  • $\begingroup$ Are you using BI or cycles? $\endgroup$ – gandalf3 Mar 4 '14 at 18:45
  • 1
    $\begingroup$ could you upload the blend file? $\endgroup$ – Vader Mar 4 '14 at 18:49
  • 1
    $\begingroup$ The viewport is most likely using the UV coords for displaying the texture. While rendering uses the material settings, which can be a different texture layout. Check your texture mapping setting. $\endgroup$ – Mike Pan Mar 4 '14 at 19:52
  • $\begingroup$ Possible duplicate of Blender UV mapping error. $\endgroup$ – iKlsR Mar 4 '14 at 20:04
  • $\begingroup$ I don't know how to get my file on here, what do I need to change to get the viewpoint and render to display the same thing? $\endgroup$ – Elimyxlov Mar 4 '14 at 22:23

Fixed it! I hadn't realised I needed to click on assign twice as I had only done it once and wasn't sure why it hadn't worked.

So it did end up being something simple that I'd missed


Not the answer you're looking for? Browse other questions tagged or ask your own question.