5
$\begingroup$

This question already has an answer here:

[edit]

I've altered my node-tree like suggested in the other post. It changed a cluster of maybe 8 pixels. The solution I'm looking for will result in straight edges without jaggies. Blurring the edges is not what I'm looking for. I need crisp sharp edges on the car. Perhaps these new images make for a better example. Again, thank you for your time and effort!

Cheers!

enter image description here enter image description here

[original post]

Hello people of this fine community!

I'm having a problem with jagged edges on the geometry of the roof of the car in cycles render and I have no clue how to smooth them out.

Render samples are set to 1000.

I have 3 render layers: 1 with the car, 1 with geometry acting as a shadowcatcher and 1 with the background image. There's 1 big lightsource.

When blender is busy rendering the geometry of the car and there's still a transparent background, the roof of the car is smoothed out. The jagged edges only become visible when all renders are put together in the composite at the end.

I actually quite like it. Sentiment for oldschool games I guess but my projectleader is not having it..

nodes

Please help!

Thanks in advance!

$\endgroup$

marked as duplicate by David Mar 8 '17 at 15:10

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 3
    $\begingroup$ Try to enable antialiasing for all Mask-Id nodes and see if that helps. Also this answer: blender.stackexchange.com/a/67371/31447 is a great one (when it comes to render layers). $\endgroup$ – brockmann Mar 8 '17 at 13:44
  • $\begingroup$ Thanks for the comment, alas the antialiasing for all Mask-Id nodes sadly doesn't make it better. Also, I've been staring myself blind, I never noticed these checkboxes on the Mask-Id nodes xD Could it have something to do with not having a very good graphics card in this machine? $\endgroup$ – Robert Zuman Mar 8 '17 at 13:58
  • $\begingroup$ This could be caused by the mishandling of alpha types. See this. $\endgroup$ – Mentalist Mar 8 '17 at 14:24
  • $\begingroup$ Hmm, okay but I don't use an alpha over node. I'm only a beginner and I don't know if I'm mishandling alpha types and if I am I didn't mean to hurt anyone. $\endgroup$ – Robert Zuman Mar 8 '17 at 14:35
  • $\begingroup$ My apologies for creating a duplicate post David. Thanks for pointing it out. I'll try and figure out how to implement this into my own node-tree $\endgroup$ – Robert Zuman Mar 8 '17 at 15:40

Browse other questions tagged or ask your own question.