0
$\begingroup$

Good evening,

i have got weird shadows on my mesh. No matter what lighting i've got - problem is still there.

Clearly it has something to do with topology. But the topology is pretty good so it's strange..

It is possible to fix them in static character's posture, but when i animate the character - problem reappear since geometry changes again in those problematic places.

What's the magic button to fix all the problems? :D

Things i've tried: * Recalculate normals * Make planar faces * Edge split modifier * Remove doubles

Blend file: (somewhy doesn't show up well as it used to before)

Prob

$\endgroup$
1
$\begingroup$

Your model is huge, and that is causing lots of problems.

Specifically for those shadows Ambient Occlusion is to blame. The model is so huge that even with the insane values you have for ambient occlusion, it only affects small creases in the model, but with great intensity. If you disable ambient occlusion however you get another issue: everything is dark.

The way you have set up your background node does not affect your model, so no environment light exists. You could either remove the camera ray constraint from the world texture, use a nice neutral grey for background and use the compositor to set up a background color, or keep it and add some lights to your scene.

However adding lights does nothing, unless you crank up the intensity to hundreds of thousands, another issue with the size of your model.

I'd say just resize your model to a more manageable size (something like a real human): then both AO and lights will work as expected with sane values.

screenshot

$\endgroup$
  • $\begingroup$ Thanks for the response. Tried totally without AO and only with lights - it's the same. Most likely the size is the problem here. Will let know how it goes. $\endgroup$ – Ignac Mar 7 '17 at 20:06
0
$\begingroup$

This might sound crazy, but i fixed the problem by making the character even larger... :D She is now 456km high :D

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.