0
$\begingroup$

I recently got a 3Dconnexion Spacemous and everything worked perfectly, at least in the training setup. Now I tested the device in blender and even though the control of the viewpoint works excellently I can not rotate/move objects, like the cube in the startup example. I read some posts, with older timestamps stating that this option is no available, but really? It worked in the training why does not it work in blender. There must be some solution to this problem since I can not be the only one who wants to use such a feature. Please help!

$\endgroup$
  • 1
    $\begingroup$ I'll mention the obvious - at the bottom of the 3D screen is an icon that has two arrows pointing outward from each other. "<--...-->" It toggles the lock on rotate etc. That might have got itself activated. $\endgroup$ – Edgel3D Mar 6 '17 at 18:26
  • $\begingroup$ Did the training demo show it actually working in Blender? If not you can't just expect it to work because it worked in some other software under a controlled environment. $\endgroup$ – Duarte Farrajota Ramos Mar 6 '17 at 19:45
  • $\begingroup$ @Edgel3D unfortunately the obvious is not the problem. I am able to rotate the cube with the normal mouse. Just with the space mouse i can not get it to rotate. $\endgroup$ – mrks Mar 7 '17 at 7:29
  • $\begingroup$ @DuarteFarrajotaRamos the training demo was some other program, I just mentioned this because I do not think that blender does not support this function since the function works in other software. $\endgroup$ – mrks Mar 7 '17 at 7:30
1
$\begingroup$

Moving objects with the Spacemouse has not been implemented in Blender, but good news is somebody is working on it! See How can I move an object using NDOF?

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.