2
$\begingroup$

When I click P for game engine the objects which have material their color become dark.For example the station has blue color in texture mode,but on game engine is dark blue and etc.How to make the texture to have the same color on GE as in texture mode?

$\endgroup$
3
$\begingroup$

It sounds to me like you are struggling to get the image you see in the viewport to align with how your game performs in realtime. This is usually the fault of Multi-Texture shading, which is the default in-game render mode for BGE. If you want the game to look the same in and out of game, change the shading mode to GLSL. Here is what my scene looks like when I see it in the Blender 3D view, or viewport.

enter image description here

Once I hit P though, it looks terrible!

enter image description here

The good thing is, this is an easy fix. Just click multitexture, and select GLSL in the dropdown menu. The tool bar that has this option can be opened and closed in the 3D view by pressing N.

enter image description here

Ah! Much better. As you can see, it matches the way i thought it should look from the 3D view perfectly!

| improve this answer | |
$\endgroup$
  • $\begingroup$ I tried that,but everything becomes dark.How can I fix it? $\endgroup$ – Ivelin Mar 6 '17 at 18:49
  • $\begingroup$ @lvelin it's probably still a related issue. If you could post an image or a file it would allow me to help you much better. :) $\endgroup$ – Scalia Mar 6 '17 at 19:12
  • $\begingroup$ Do you know how to add a sound of an EXE file which belongs to Blender? $\endgroup$ – Ivelin Mar 9 '17 at 17:17
  • $\begingroup$ @Ivelin unless it's directly related to this particular issue I recommend asking a new question. :) Your query will get a lot more attention and in depth answers there. And yes, I do ;) $\endgroup$ – Scalia Mar 9 '17 at 17:18
  • 2
    $\begingroup$ @Ivelin It's really important to me to know what the heck you are talking about . . . Blender has no sounds, and a .exe can only reference sound files in a file structure. Please tell us what you a) are trying to achieve and b) how you are trying to do it. Also, while this is related to the same project, it most definitely has nothing to do with textures. Please ask a new question for this after doing some more research. $\endgroup$ – VRM Mar 9 '17 at 17:33
0
$\begingroup$

One thing that might help may be to make the lighting in the Blender 3D viewpoart mimic as closely as possible the lighting in the Game engine. If the lights in the modeling viewport are in different types, of different colors, in different locations relative to the object and the cameras, the textures will look different. Replicating the lights and cameras as nearly as possible will reduce the difference.

| improve this answer | |
$\endgroup$
0
$\begingroup$

There's also one thing that affect a lot. Blender uses a sistem to color thinks called sRGB that was thought for very old computers. It makes everything darker. You should use a cor system called "Filmic blender" and also make brighter lamps. You can inform about this in: http://www.blenderguru.com/tutorials/secret-ingredient-photorealism/

| improve this answer | |
$\endgroup$
  • 1
    $\begingroup$ Better read it here: blender.stackexchange.com/a/46940/31447 (instead of watching this boring tutorial). BTW: The question is about game engine. $\endgroup$ – brockmann Mar 6 '17 at 18:35
  • $\begingroup$ Where is that option Filmic blender? $\endgroup$ – Ivelin Mar 6 '17 at 18:50
  • 1
    $\begingroup$ This has nothing to do with OPs question. $\endgroup$ – JtheNinja Mar 6 '17 at 21:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.