When LMB clicking the mouse is replaced by a red circle. This unfortunate behaviour occasionally disappears.

enter image description here

How can I get rid of that? (I can't connect nodes properly, because the cursor changes.)

  • $\begingroup$ Looks like Erase of the grease pencil. However, this should not appear in this context. Also I can't confirm, works as expected on linux. What Add-ons are enabled? $\endgroup$
    – p2or
    Commented Mar 3, 2017 at 11:16
  • $\begingroup$ @poor Thank you, you are correct it was the eraser. I have already added an answer. The pen was to close to the graphics tablet. $\endgroup$
    – Leander
    Commented Mar 3, 2017 at 11:40

1 Answer 1


[Few minutes later.]

That is the Grease Pencil Eraser.

Make sure there are no other inputs except for the mouse. In this case there was a graphics tablet with the pen in near proximity.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .