15
$\begingroup$

enter image description here

I want to use the top half of the circle to make a cut but whenever I apply the boolean modifier, the circle just stays there and becomes attached to my other object.

I've managed to make the cut in a standard cube but not sure why it's not working for this...?

$\endgroup$
11
$\begingroup$

That's because of the limitation of approach of how inner/outer surface are calculated in Boolean modifier. Current Boolean uses Carve library. Carve will perform boolean operation only if the intersection of two meshes is a closed loop of edges.

As shown in your image, the object is not a closed manifold one, which confuses the edge classifier. This is listed in Boolean modifier limitation.

To solve this, I suggest adding a Solidify modifier on top of Boolean modifier, with a very small Thickness Value (such as 0.00001). After applying both modifiers, you can press W > Remove Doubles to clean the mesh, and select all faces, then press Ctrl N to correct normals. (This sounds like a trick, but it works in this case, since there's nothing you can do with the current Boolean approach, which got its own advantages as well as limitations)

enter image description here

Example file

By the way, in the coming 2.70, Boolean modifier supports ngons, which means you can generate much better and cleaner results (as shown in above image). You may want to give it a try.

$\endgroup$
7
$\begingroup$

There might be a problem with the normals. Select the Cylinder and go into edit mode, and recalculate the normals, Ctrl N. Do the same for the box object.

  1. Select the Box like object (not the cylinder).

  2. Add a boolean modifier

  3. Select the cylinder as the Object in the Boolean Modifier settings

  4. You need to set the boolean modifier to difference.

enter image description here


If you have other modifier on the mesh you might need to apply those first, before you apply the boolean modifier.

$\endgroup$
  • $\begingroup$ I have but it still doesn't work... $\endgroup$ – user2302835 Mar 2 '14 at 22:33
  • $\begingroup$ @user2302835, updated answer $\endgroup$ – Vader Mar 2 '14 at 22:55
0
$\begingroup$

Try the triangulate modifier on both shapes.

I also had the problems with larger models that are may of not perfect quality. I also made some afford in building the model with quads or remiss all didn't work.

In these cases put a triangulate modifier on both shapes and place the boolean modifier afterwards.

$\endgroup$
0
$\begingroup$

Boolean Prep - Subdivide

I think I've gotten around that by selecting just the faces which are going to be cut and subdividing them a few times prior.

I'm suspecting that the additional geometry helps give the Boolean operator more to work with.

Boolean Anomaly I did get a slight anomaly on the inside of the wheel well but looks easy to fix if I feel like it and it'll be hidden by the tire anyhow.

Overall I'm finding that additional geometry helps with a lot of things in Blender and I'm slowly getting better at targeting where and how I place that.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.