1
$\begingroup$

So I am new to all of this and at my wits end. I can't seem to get a rig to parent to the model mesh it gives me an error every time. I have tried everything that i have been able to find out about. i appended rig to other mesh so rig is fine.

Things I Have tried.

  • remove doubles
  • recalculate outside
  • remove all modifiers,vertex groups,shape keys,and UV data
  • corrected non manifold
  • applied decimate modifier
  • removed all model acc (ie clothes)
  • symmetrize model

Like I said I am new so maybe I overlooked something simple.

$\endgroup$
  • $\begingroup$ I also suffered from this. If all else fails, you may have to separate the mesh into multiple parts and parent the rig to each separate piece individually, then rejoin the parts. See developer.blender.org/T45493. You could also try installing Blender 2.70 and try the rigging. Then update to 2.78 again. $\endgroup$ – TTTTTTa Feb 20 '17 at 10:11
  • $\begingroup$ If you are trying automatic heating then look at my answers here: blender.stackexchange.com/questions/72185/… $\endgroup$ – Grimlock Feb 20 '17 at 10:21
  • $\begingroup$ @TTTTTTa and Grimlock Thank you both i have not been able to completely fix my problems yet but thanks to both of your posts i was able to isolate the problem area within my mesh. I am not sure why it was a problem but after removing the area i was able to parent it in sections it still does not work right but it was at least progress so thanks again. Also for future reference how do i upload a blend file with posts i may make? $\endgroup$ – noobtrng2lrn Feb 22 '17 at 4:56

Browse other questions tagged or ask your own question.