0
$\begingroup$

I can't assign smooth shading to my object (clicking smooth in the shading tab on the left side yields not result). When trying to find out why I noticed that it doesn't have a material in the material panel (bottom right). Why?

This is a custom shaped object I made from a cylinder mesh.

enter image description here

$\endgroup$
2
  • 1
    $\begingroup$ Looking at your screen short, I suspect that the object does have a material. The material context button is set for materials, but the slider in the properties pane is not at the top of its range, and is far enough down, that the top panes are not visible.If you move the slider up, you will at least find the dialog box for adding materials. $\endgroup$
    – brasshat
    Feb 20 '17 at 4:02
  • $\begingroup$ You need to be in "Object" Mode to set the shading to smooth. $\endgroup$
    – Dontwalk
    Feb 20 '17 at 12:39
2
$\begingroup$

On the bottom right, scroll up and you will see the panel to add materials. Even if you don't assign a material to your mesh the smooth shading option should still work. From what I can see, your mesh just has inverted normals. Go to the panel on the left and click "Recalculate" if that doesnt work, then click "Flip Direction".

$\endgroup$
2
  • $\begingroup$ Thanks for pointing out that I needed to scroll up and that my normals were inverted, but I still can't get smooth shading. I click smooth on any of those options on the top left and they do nothing. $\endgroup$ Feb 22 '17 at 20:51
  • $\begingroup$ can you post some pictures? Or a blend file? Perhaps smooth shading works but not like you were expecting it to? $\endgroup$
    – Cos Dim
    Feb 23 '17 at 19:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.