0
$\begingroup$

It seems that whenever I save my file, it gets bigger and bigger no matter what I do. Why is this happening? At first I thought baking might have been causing the problem, then I tried reducing the number of particles (smoke) to something much less and it still produced a massively large file. Finally, I simply saved it without doing anything to the file and it still grew to the same huge file size. I've attached a link to the .blend.

.blend file

Thanks!

$\endgroup$
1
$\begingroup$

The Cache of ParticleSystem saves with the file (apparently).

Removing ParticleSystem from Sphere.001 reduces the file size. Reducing the Number of Emitted Particle from 500000 to 1 does the same.

Detailed Steps

  1. Select Sphere.001 on Layer 2.
  2. Go to the Particle System Tab. As you can see it has 20 users. Remove the particle system.
  3. Select the other users and remove the particle system from each.
    Plane_cell.013 ,
    Plane_cell.461 ,
    Plane_cell.464 ,
    Plane_cell.464 ,
    Plane_cell.543 ,
    Plane_cell.545 ,
    Plane_cell.623 ,
    Plane_cell.627 ,
    Plane_cell.648 ,
    Plane_cell.713 ,
    Plane_cell.728 ,
    Plane_cell.743 ,
    Plane_cell.754 ,
    Plane_cell.757 ,
    Plane_cell.763 ,
    Plane_cell.771 ,
    Plane_cell.834 ,
    Plane_cell.854 ,
    Plane_cell.875.
    They are easy to locate in the outliner, since they have the modifier icon next to their name.

While it is best practice to create a separate cache directory, you may have assigned the particle system to some objects by accident, thus increasing the performance cost (more particle emitting objects).

$\endgroup$
  • $\begingroup$ That's odd for some reason removing the particle system doesn't reduce the file size for me. How do you clear the cache for ParticleSystem? $\endgroup$ – lakerice Feb 19 '17 at 21:09
  • $\begingroup$ @lakerice I have added additional notes to the answer. Edgel3D answer also holds important information. $\endgroup$ – Leander Feb 20 '17 at 8:12
  • $\begingroup$ Oh now I see! I have no idea how I assigned particles to those objects, but I'm glad I was able to remove them. And yes, from now on I'm caching to a separate directory and it's working out great. $\endgroup$ – lakerice Feb 21 '17 at 0:42
1
$\begingroup$

I observed this only last night! I have two particle systems running and what was a half MB Blender file before the particles were added, suddenly increased to some unbelievable size! (can't remember, but it was huge!) I then switched on the caching and nominated a spare folder.

No baking is involved and when running it, the particles ceased to appear, BUT - the filesize when resaved returned back to 600 KB. I cleared everything including Blender's temp buffer, caching folders etc so when it was reloaded there wouldn't be any hangovers.

The particle settings I'd made were still intact, so I switched off the caching and everything returned as before, particles and all!

My procedure now for this particular project is, prior to a final save, tick the caching box for EACH EMITTER, then save. When reloading, switch it off again. No more humungous filesizes!

Note again - for this to work properly you must nominate a folder for caching.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.