I am having problems baking textures with Cycles in Blender and am getting pretty frustrated, even earlier today it was working fine, but now every texture I bake turns out solid black. I figured I had messed up my blend file somehow so I created a brand new one from scratch and the same thing is happening.

I have a single material on a simple object, it is UV unwrapped and the UV's are definitely pointing in the right direction. I have multiple area lamps in the scene and if I render the scene it all looks just as it should. I have an image texture I've created to render my bakes to and have added a texture node for that to my material. The texture has been selected there and there is a yellow highlight around the node so Blender knows which image texture I want to render to.

But, when I click bake with either combined or diffuse selected it takes about a minute, and every time leaves me with a black render. This is a very simple process that has worked for me in the past so I am quite frustrated that it just seems to have stopped working for some reason. Can anyone tell me what I might be doing wrong?

Thanks in advance.

  • Welcome. What you describe usually happens when baking is done from texture with no data, e.g. you bake to texture which is used as texture for shaders (loop dependance, Cycles warns you about that in the Info editor but doesn't stop baking), or you bake diffuse when there's no diffuse shader connected (e.g. if only Emission shader connected to Material Output); there could be other ways. It's hard to tell more without screenshots and if possible file. – Mr Zak Feb 18 '17 at 19:24

I believe I solved my problem. There was a hidden object in my scene, it seems that hidden objects are not included when rendering, but they are when baking. The hidden object was a cage for the object I was trying to bake so it was blocking all light to that object which resulted it just a black texture.

Your Answer

 
discard

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.