3
$\begingroup$

I used Rigify to create a rig for a character that I want to animate. I added in a human meta-rig and formed it to fit the human model. The problem occurs when I click generate under the Rigify buttons category. It does not create points for me to manipulate for the fingers, elbows or knees or a full skeleton for the character. Any ideas why?

this is the outcome of what I made

the rig when it is formed to the body

the solid view

$\endgroup$
  • $\begingroup$ I guess you are using rigify? Please attach some screenshots showing your right, your model and the resulting animation rig. $\endgroup$ – Gunslinger Feb 27 '14 at 11:32
4
$\begingroup$

Make sure 'Auto Run Python Scripts' is ticked in the File -> User Preferences Menu. I had the same problem and that fixed it.

|improve this answer|||||
$\endgroup$
  • $\begingroup$ Umm... no. Where the heck is that tickbox?! $\endgroup$ – Nefer007 Jun 11 '15 at 19:48
  • $\begingroup$ Under the File -> User Preferences -> File Tab, near the bottom $\endgroup$ – That One Actor Jun 30 '17 at 23:20
  • $\begingroup$ For anyone coming across this as of 2.80, it's now in the Edit -> Preferences -> Save & Load menu $\endgroup$ – galois Jan 21 '19 at 4:16
3
$\begingroup$

Armatures have their own layering system - similar to the layers available in the 3dview - only bones on active layers will be visible. Rigify uses these layers to group various related bones together, eg the finger bones are all on one layer, arm.L(IK) bones are on another and so on.

Rigify also creates a panel that is shown in the properties sidebar of the 3dview (N) that has buttons to enable the various bone layers using more useful names. These buttons are just a convenience that relate to the bone layers available in the armature properties.

enter image description here

|improve this answer|||||
$\endgroup$
1
$\begingroup$

Last Box to Check Under File > Blender Preferences > "File Tab" then at the bottom where it says "Auto Execution" ..It fixed it for me.

|improve this answer|||||
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.