3
$\begingroup$

I have been following this makehuman tutorial, and was able to find the FK/IK switch through this question for the same tutorial. I have followed the import settings (override exported data, add rig > exported MHX/MHX), but when I move the root bone up and down, the rig bends at the knees but the model does not.

The image on the left is the tutorial video, with knees bent. The image on the right is my project file - the rig is bent, but the knees are straight.

Image on left is tutorial video rig with legs IK switch, right is my rig with legs IK switch. Notice that the rig is bent in both, but my model's legs are straight.

Is there a setting I am missing from my Makehuman export or Blender import? Or have I missed a setting in one of the panels? I am also thinking it may just be better to use makehuman's game engine rig, or else create my own rig with rigify, as recommended in this thread.

For further clarity on the problem, the image below shows what happens when the root is selected, and then moved using the transform ("G" on the keyboard). Character does not bend using IK

Blender 2.78a, makehuman 1.1.0, running on a Windows 10 PC

My .blend file can be found here:

$\endgroup$
  • $\begingroup$ Not sure what is the problem? It makes sense that with IK the knees will bend when moving the root bone, I don't know what is the problem? what is the expected result? $\endgroup$ – Tak Feb 13 '17 at 23:09
  • $\begingroup$ The image on the left is the tutorial video - it is working correctly, and the knees have bent. The image on the right is my project file. The rig has bent, but the knees remain straight. The expected result would look identical to the image on the left. $\endgroup$ – Zeesy Feb 13 '17 at 23:17
  • $\begingroup$ Please provide your .blend file on blend-exchange.giantcowfilms.com to be able to help you $\endgroup$ – Tak Feb 13 '17 at 23:18
  • $\begingroup$ File located here: <img src="http://blend-exchange.giantcowfilms.com/embedImage.png?bid=2739" /> $\endgroup$ – Zeesy Feb 13 '17 at 23:25
  • $\begingroup$ I'm confused the attached file is rigged and works fine for me. The rig does use a number of drivers. My guess is you need to turn on Auto Run Python Scripts Nevermind just saw your answer lol. $\endgroup$ – batFINGER Mar 19 '17 at 16:53
1
$\begingroup$

I found the solution: activate auto-run of Python scripts in Blender by selecting Auto Run python scripts in user preferences.

activate pythin scripts under the File settings

$\endgroup$
0
$\begingroup$

You need to select the root then press G and move the mouse and it will works perfectly as shown below:

enter image description here

enter image description here

$\endgroup$
  • $\begingroup$ In this case, selecting the root, pressing G and moving the mouse does not result in the IK movement in your picture above, but instead results in the movement of the static pose. See my question for a second example. $\endgroup$ – Zeesy Feb 16 '17 at 17:23
  • $\begingroup$ @Zeesy I don't understand what you mean? $\endgroup$ – Tak Mar 4 '17 at 11:01
  • $\begingroup$ Thank you for following up, @Tak. If you look at your images in your answer, both the rig and the model are bent. If you look at my images in my question, you will see that the rig has bent, but the model is still standing. When I import the model into Unity, I can apply animations and poses from there, but I have to adjust the model bone by bone in Blender. $\endgroup$ – Zeesy Mar 5 '17 at 17:19
  • $\begingroup$ @Zeesy so in my images it is working correctly as you want? $\endgroup$ – Tak Mar 5 '17 at 21:16
  • $\begingroup$ Yes, @Tak, in your images it's working, in mine it's not. $\endgroup$ – Zeesy Mar 6 '17 at 18:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.