0
$\begingroup$

I set up my background to sky texture but when rendered it shows black, here is a picture of it:

enter image description here

enter image description here

$\endgroup$
6
  • $\begingroup$ Please show your world material node setup. $\endgroup$ Commented Feb 11, 2017 at 11:43
  • 2
    $\begingroup$ Please read the rules of the site; do not add an answer when providing additional information, edit your question instead. As for your question - is Camera option unchecked in World tab > Ray Visibility rollout ? $\endgroup$
    – Mr Zak
    Commented Feb 11, 2017 at 12:55
  • $\begingroup$ it was checked so i unchecked it but still same problem! $\endgroup$
    – Moun Glow
    Commented Feb 11, 2017 at 13:00
  • 1
    $\begingroup$ It is meant to be checked. It controls whether world texture is visible for camera (i.e. rendering) or not. Is it possible for you to upload the blend file on this link ? $\endgroup$
    – Mr Zak
    Commented Feb 11, 2017 at 13:14
  • 1
    $\begingroup$ just uploaded the file sorry if its a bit large, please check it out. $\endgroup$
    – Moun Glow
    Commented Feb 11, 2017 at 13:38

1 Answer 1

1
$\begingroup$

You have Transparent enabled in render settings > film.

enter image description here

Disable that and you'll see the sky...

$\endgroup$
2
  • 1
    $\begingroup$ Generally if Transparent is checked it should show checkerboard which means transparency, not solid black. For some reason this is caused by Background Images in the Properties shelf (the rollout is just enabled, there aren't any). Don't know if it's a bug. $\endgroup$
    – Mr Zak
    Commented Feb 11, 2017 at 15:43
  • $\begingroup$ @MrZak Yes, it took me a little while to find that, and it wasn't exactly what I was expecting when I saw it. It could very well be a bug... $\endgroup$
    – JakeD
    Commented Feb 11, 2017 at 15:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .