0
$\begingroup$

I'm playing with fluid simulations (Blender 2.78b). There is something quite odd. When I bake my fluid, sometimes it works, sometimes it acts as if some parameters (inflow velocity ? speed ?) were ignored when baking.

normal baking normal baking

broken baking enter image description here

I didn't change anything between those two versions, the only difference could be that I did animate the "Enabled" checkbox (Fluid tab from the Physics panel), but I'm not even sure I did; I think this is a bug.

Has anyone experienced the same thing / does someone knows why I got this ?

Thanks !

$\endgroup$
  • 1
    $\begingroup$ How can you not be sure whether you animated the enabled checkbox or not? Baking will be exactly the same every time until you change something. $\endgroup$ – Ray Mairlot Feb 10 '17 at 16:11
  • $\begingroup$ I did notice this when making tests with the checkbox. And I'm not sure that it is why my baking is altered. Let's say it is enabled at frame 0 and that I disable it at frame 100. The 100 first frame of the animation should be the same. And they are not. As it looks like a bug, i'm not sure that it is related to the checkbox thing or not. $\endgroup$ – gordie Feb 10 '17 at 16:51
0
$\begingroup$

Did you change the fluid cache? There's an option to change where the cache is outputted (under Physics in the domain object), and if you change the parameters and bake again without changing the cache output, it can cause glitches in the new bake, because of the discrepancies between the parameters you changed and the parameters set in the cache from the previous bake.

$\endgroup$
  • $\begingroup$ Nope, I didn't... :/ $\endgroup$ – gordie Feb 11 '17 at 0:46
  • $\begingroup$ Oh well, try making a new cache, see if that works. $\endgroup$ – Gecko_Lord Feb 12 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.