0
$\begingroup$

enter image description here

I'm having a rigify error after applying 'with automatic weights'. My character's hair is floating after I move around the rig and it's frustrating that I have no idea how to fix it. I don't know how to manually weight paint either. (I'm a big noob)

$\endgroup$
  • $\begingroup$ Answer provided, there are couple of things that may solve it. You can upload your .blend file on blend-exchange.giantcowfilms.com $\endgroup$ – Tak Feb 9 '17 at 8:35
0
$\begingroup$
  • Select your mesh and Switch to Weight Painting mode using ctrl+Tab
  • Select your armature and switch to Pose mode using ctrl+Tab
  • Rotate your head bone as shown in the figure you posted, which will leave the other parts of the head not moved.
  • Now select your head bone and start weight painting using Mouse left click as shown below until all these parts are red, where these parts of the head will be assigned to the bone head and will move with it. You may need to turn off the limit selection as highlighted below

enter image description here

$\endgroup$
  • $\begingroup$ I just got this showing up. Thank you so much. So it didn't apply anything to it at all. Not only that. You taught me how to clean up weight painting. Thank You!! imgur.com/50UjcoT $\endgroup$ – Cody Mavar Feb 9 '17 at 8:42
  • $\begingroup$ @CodyMavar You are welcome, glad I helped. you can accept the answer if it solved your problem :) $\endgroup$ – Tak Feb 9 '17 at 8:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.