0
$\begingroup$

Actually, it is very weird, since the uv works on some model parts and not on others. It shows up in the materials but not in the render. The UV is mapping correctly to the wheel strut. The left wheel is fine, the right is just black.

There is a sun lamp and the world background is set to white.

I tried the attributes node and the texture coordinates method. As you can see from the screen shot, it does map correctly. It just won't render.

I also tried flipping the normals. Although I don't understand that part technically yet.

Since I can see it with the 3d view set to materials, does that mean that the mesh is bad? The file came from tf3dm.com . I tried the .3ds import but that one was missing parts and blown apart.

Here's the screen shot of my import and attempts. Screen shot of 3d view set to materials, node editor, uv map with highlighted map coordinates, and the 3d view set to render

Here's the blend file: Link to mq9predator.blend file.

$\endgroup$
  • $\begingroup$ You should upload the blend file in order to help to understand the problem here (pack the textures with it). Use this site : blend-exchange.giantcowfilms.com . The obtained link can be use editing your question or in the comments. $\endgroup$ – lemon Feb 8 '17 at 18:57
  • $\begingroup$ Thanks @lemon I have uploaded it in the question. Should have done that the first time. Sorry! $\endgroup$ – Matt McKee Feb 8 '17 at 21:10
1
$\begingroup$

I found the answer!

After digging around and hitting random settings on just about any button and setting known to man, I discovered the Geometry Data under the Object Data (to the left of materials panel).

I hit Clear Custom Split Normals Data and the map showed up in the render! Now to figure out what the heck a custom split normal data is...

$\endgroup$
  • $\begingroup$ Custom split normals are a way to split normals of the faces (vectors perpendicular to them) in a custom way in order to get desired shading on the mesh surface. They could be exported from another program if you didn't alter them in Blender e.g. with Normal Edit modifier. $\endgroup$ – Mr Zak Feb 8 '17 at 21:44
  • $\begingroup$ Thank you, @Mr Zak. I am pretty sure this model wasn't made in blender. This proves it. Ah, more research! Thanks for giving me a new search term. $\endgroup$ – Matt McKee Feb 9 '17 at 4:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.