1
$\begingroup$

I am having the exact same issue as discussed in this thread: Why does this texture appear fine in material view but appears pink in rendered view?

Tutorial from https://www.youtube.com/watch?v=xU_pi1UxISs

The image file is not missing - I have used "find missing files", as well as assigning and unwrapping again. The image shows up in the 3D view but is only visible as pink in the render view. I have exported the file from PS as a TIFF with alpha. Is this a bug or am I and Sarsha W doing something wrong?

I'm running Blender 2.78a on a PC.

BTW, I've been going step by step from this tutorial, and the alpha channel texture is the only one with this problem

$\endgroup$
10
  • $\begingroup$ Did you try to save the file and reopen it? $\endgroup$
    – Denis
    Commented Feb 7, 2017 at 16:54
  • $\begingroup$ Yes, and it's still pink. Does it have anything to do with how the surface was originally modelled? It was created by making a duplicate from a selection of the cup's ribs (see the tutorial from 11:35 $\endgroup$
    – Zeesy
    Commented Feb 7, 2017 at 16:59
  • $\begingroup$ No, the pink color means that blender doesnt have access to the image file. Try to reopen it. $\endgroup$
    – Denis
    Commented Feb 7, 2017 at 17:01
  • $\begingroup$ I've been opening and reopening since yesterday. Following exact instructions from here in the tutorial. Once I have opened the image under image texture, it is still pink. File path is correct, no missing files when I use File > External Data > Report Missing Files. When I unwrap, make a new texture, save and reopen it's still the same problem - texture is visible in the 3D view but not render view. Sarsha W has been having the exact same problem, posted 3x about it and still hasn't resolved. I'm using Blender 2.78a on a PC, if that helps. $\endgroup$
    – Zeesy
    Commented Feb 7, 2017 at 17:22
  • 1
    $\begingroup$ I'd say this is a bug which was eventually resolved by packing. $\endgroup$
    – Mr Zak
    Commented Feb 7, 2017 at 18:42

1 Answer 1

2
$\begingroup$

Rick Riggs suggestion to pack the image file:

Blender-> File -> External Data -> Automatically pack into .blend

worked like a charm. Once I checked that, the texture was applied to the surface. .blend after packing image data

For help packing images: Packing Texture Files In a Single Blend File

$\endgroup$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .