0
$\begingroup$

So I've been learning Blender for the last week or so and have been having a blast!

I did stumble onto a very frustrating problem though. Whenever I duplicate an object using Shift+D, it creates a linked duplicate as if I had used the command Alt+D instead. I first noticed this during a tutorial where the presenter duplicated an object several times and then rotated each one individually. Mine would all rotate together. I thought I might have enabled an option accidentally while following tutorials so I tested this in a brand new scene with just a cube. Sure enough after making a couple of duplicates (Shift+D), any changes made to the original were instantly copied to the duplicates.

I'm not sure if I'm missing something very obvious here, I don't think that is the normal behavior for the Shift+D function. I'm kind of at a loss. Any help would be greatly appreciated!

$\endgroup$
  • $\begingroup$ See if the shortcut for duplicating wasn't changed, related - blender.stackexchange.com/questions/6233/…. Normally Shift+D creates full copy. $\endgroup$ – Mr Zak Feb 6 '17 at 15:56
  • $\begingroup$ click on 1 object and press U > unlink object & data and then select that object then make it duplicate shift+d $\endgroup$ – atek Feb 6 '17 at 16:28
3
$\begingroup$

So I discovered what the problems was. In the User Preferences > Editing tab, the Mesh option was unchecked under Duplicate Data. After enabling it the Shift+D duplicate functions normally. I unchecked it again just to make sure that it was indeed what was causing my issue.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.