2
$\begingroup$

I have blender 2.78 and I am trying to get the depth of field to work, but I just can't make it. I think I have all that as needed the camera and the target an object, the compositing is on, I even have the cameras limits set to the target object, I tried to render it in blender internal, in cycles and in the 3D window, but nothing seems to work. I'm wondering is it possible to get the dof to work without using nodes and if it's possible what should i do. I now try to add more information that i think is needed. I have set the measurement system to metric in the scene , and the object that is the target has the value of 1.0 as size. the camera I used is canon aps-c. I have tried different focus-stop values that seemed not to help. I'm not sure what the lens is that I'm using, or where to find the lens used ? I wonder that if i have difficulties with this because I can´t somehow set the right distances between the camera and the object and do nut fully understand the relation between the metric grid, object size, and the distances and adjustment´s needed to make the depth of field seen. I have read many depth of field tutorials, but I seem to miss awarness of something very essential to get it work. I have NOT been using nodes when trying to do this . enter image description here

$\endgroup$
3
$\begingroup$

Depth of field (as defined by circles of confusion) depends on three factors:

  • The length of the lens used (in mm). Longer lenses will have less depth of field

  • The distance to the subject. The closer the camera is to the object the more critical focus will be, and the depth of field will be shallower.

  • The f stop on the lens. Higher f-stops will give you larger depth of field (more things will be in focus) Smaller f-stops will reduce the depth of field.

You are using a wide angle lens (35mm) and a very high number for f stop (31.8), and your object are quite large and far away. with those settings is very unlikely that you will see the effects of selective focus (which I presume is what you are looking for). Lower the F-stop to something like 1.4 or even less than 1 to see the effects. Also in cycles you can preview the depth of field in preview render mode.

enter image description here

$\endgroup$
  • $\begingroup$ I didi not had the dof checked in the shader´s menu . :) mayby i can get somewhere now , thanks . $\endgroup$ – node Feb 6 '17 at 15:09
2
$\begingroup$

Check dimensions of your mesh in metric length. You can't get blurry effect if your camera aiming object that too far.

To make it work without scaling down your all object, lowering the aperture rasio of your camera.

example, i create mug and in metric length, it has 3m heights. then i set aperture to f-stop with 0.8 number rasio in DoF section.

$\endgroup$
2
$\begingroup$

If you make your aperture smaller by reducing the F stop, you can get less depth of field (more blur).

To read more about depth of field, read this question: https://photo.stackexchange.com/questions/2/how-can-i-maximize-the-blurry-background-sharp-subject-bokeh-effect

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.