3
$\begingroup$

I'm currently trying to unwrap a model I've built. Aside from bevels being a pain to unwrap I've stumbled upon the following problem:

enter image description here

I'm selecting the six faces, U -> unwrap, which leads to a stretched unwrap. This also happens if I place seams around the six faces, U -> unwrap.

The weird thing is, selecting only the three big faces and unwrapping them results in straight edges:

enter image description here

Selecting the small faces beneath them, U -> unwrap though results in stretched / slightly rotated faces:

(Can't show the third images because of too little reputation ;-) )

I checked the coordinates of the vertices, but they seem to be perfectly aligned on their axis, only changing z and x values as you would assume.

I know that you could work with: project from view or maybe unwrapping the big faces and then stitching the small ones to them, but for such an easy task this seems needlessly complicated.

Am I overlooking something that creates this weird behaviour in the unwrap?

I got even more problems with the unwrap (weird rotations on other elements and as mentioned the bevels on the stuff not visible in the images) but one problem after another ;-)

Any help would be greatly appreciated!

Cheers Daniel

$\endgroup$
  • $\begingroup$ Have you tried "Unwrap--->Smart unwrap" ? Also Unwrap-->reset, and try smart after that. $\endgroup$ – Edgel3D Feb 5 '17 at 0:37
  • $\begingroup$ Maybe related to blender.stackexchange.com/questions/35203/…. Try Conformal unwrapping method for this case. $\endgroup$ – Mr Zak Feb 5 '17 at 0:38
5
$\begingroup$

Few months late, but in case anyone else needs it: if your UV maps are coming out stretched, try going back into object mode and applying object transforms, then try unwrapping again. Usually, this takes care of the issue when it occurs for me, and is the first thing I try if my UVs are stretching.

$\endgroup$
  • $\begingroup$ this fixed the problem! $\endgroup$ – MatterGoal Apr 21 '18 at 14:35
2
$\begingroup$

Thanks for the fast replies Mr Zak's reply solved my problem.

I've also tried smart unwrap before, which results in weird proportions for me unfortunately.

For completions sake if anybody with the same problem stumbles upon this question: You mark your seams (Control + E) or select the faces you want to unwrap, then press U -> Unwrap. This leads to an angle based unwrap. By pressing T you gain access to the settings for the unwrap. Under method you can switch from angle based, which seems to be more useful for organic models, to conformal. This fixed my problems and the unwrap behaves as I would expect.

$\endgroup$
0
$\begingroup$

I was having UV map distortions and noticed that my models scale settings were out of whack. I was able to fix this with:

In Object mode, select the object, then Object menu > Apply > Scale.

This sets the scale values back to 1,1,1

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.