1
$\begingroup$

I am trying to get a Glow effect in the compositor. I added Node Math (Add)

enter image description here

And now my render is black&white. What am I doing wrong?

$\endgroup$
  • 1
    $\begingroup$ The Image output from your render layer node is composed of 3 seperate color channels that are mixed to show a full color image. The math node collapses these three different channels into three identical channels. Therefore there is no variation between them to display color. You would need to split the channels using a Seperate RGB node, then do math on one or all, then recombine using a Combine RGB node. $\endgroup$ – 3pointedit Feb 4 '17 at 4:18
  • $\begingroup$ Also try just using the Color Mix node and set its function to Add. This should do what you want. $\endgroup$ – 3pointedit Feb 4 '17 at 4:20
  • $\begingroup$ @3pointedit please write your comment as an answer $\endgroup$ – cegaton Feb 4 '17 at 8:13
  • $\begingroup$ I was going to do @cegatron that but I didn't have access to blender to include illustrations, which I felt made the answer sub par. So I just helped instead. $\endgroup$ – 3pointedit Feb 4 '17 at 12:10
2
$\begingroup$

Like 3pointedit already said in his comment, the problem is the math node.

An option to solve your problem is using the Seperate RGBA node for both pictures and use the math node for each channel seperately. Afterwards combine the channels again with the Combine RGBA node.

Or, again referring to 3pointedit, use the Color Mix Node.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.