0
$\begingroup$

Sorry if this question already exists, but I didn't find the answer to my problem.

(BLENDER v2.78)

I recently had the idea to animate a toon-style Rubik's Cube. I used Blender Render. I added 26 Cubes to the scene and added assigned simple materials for each color. For scrambling it I selected manually the 9 cubes I wanted to move, rotated them and set the keyframe. Everything worked perfectly and I got this result:

h*ttps://i.stack.imgur.com/JyJcb.png (I can only post 2 links)

Then I wanted to animate a whole solving process with the same file. I deleted all the keyframes and scrambled the cube with selecting all the 9 cubes of one side and pressing e.g. R + X.

After scrambeling I've set the keyframes just the same way like I did during scrambeling and got this result just in the middle of the scrambled postion and the "1st move keyframe" (Only one 90 degrees rotation along the global x-axis after scrambeling it):

Problem

I regarded the Location of the strange tiles and saw that also the y and z coordinated have been modified.

Can someone please help me. I don't know what happened and how I can fix it.

The File:

Rubiks Cube.blend

$\endgroup$
  • $\begingroup$ can you provide the .blend file? $\endgroup$ – Reaper Feb 3 '17 at 21:13
  • $\begingroup$ Looks like your new keyframes are interacting with some old (remaining) keyframes. In the Dope sheet, it's not hard to have some animation strips hidden. This can be due to a setting somewhere that is excluding a particular object. e.g. an 'eye' button in the Outliner panel hiding object keyframe strips in the Dope Sheet. You think you've cleared all animation when it's just possible that you may not have. (I've fallen for that trap more than once) $\endgroup$ – Edgel3D Feb 4 '17 at 0:03
  • $\begingroup$ Your problem is related to this question. $\endgroup$ – binweg Feb 4 '17 at 8:24
0
$\begingroup$

As binweg found in another post, the problem has been the Euler Rotation. I changed the rotation of every cube to Quaternion and everything worked as it was meant to be.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.