-1
$\begingroup$

I TRIED TO USE FLIP NORMALS AND I STILL HAVE THIS PROPLEM

BEFORE I PRESS P BUTTON

AFTER I PRESSING P BUTTON THAT'S WHAT HAPPEND

$\endgroup$
  • $\begingroup$ This title sounds like a duplicate of This Post However, the question itself sounds like a different problem all together. $\endgroup$ – Rick Riggs Feb 2 '17 at 20:54
  • $\begingroup$ @Rick Riggs no not the same i know im in the game mode look the diffrent between the two pics how the building damadged when i run game mode $\endgroup$ – Mohamed Sharkwy Feb 2 '17 at 20:58
1
$\begingroup$

This is a Z-sort issue, caused by objects having transparency, and the game engine not quite knowing how to deal with it.

In the material settings, objects should be set to the first one that gives the result you want:

  • Opaque
  • Clip Alpha
  • Alpha Antialiasing
  • Alpha Blend or Alpha Sort

ie: if you have something that does not need transparency, make it opaque. If you have something that only has clear bits and opaque bits, make it clip alpha, and so on down the list, each giving a slighly more 'advanced' but more processor intensive alpha.

| improve this answer | |
$\endgroup$
0
$\begingroup$

Take a look at all your materials and make sure they are not set to transparent. Even if they are 100% alpha, it will sometimes act weird when turned on.

| improve this answer | |
$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.