1
$\begingroup$

This question already has an answer here:

Okay so I made a model for a friend to teach them how to use blender but the textures aren't appearing as their model is hot pink/blank. I sent the model and textured files inside a zip file but it's still not working. Does anyone know how to fix this?

I'm still learning myself but any and all advice would be greatly appreciated and due to copyright reasons I cannot upload the model.

$\endgroup$

marked as duplicate by cegaton, Denis, Timaroberts, Duarte Farrajota Ramos, David Feb 2 '17 at 22:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

4
$\begingroup$

By default, Blender does not save images as part of the .blend file (this applies to background images or textures used as part of the scene).

To make those images part of the file they have to be packed.

You can pack all external files into the .blend file by going to File -> External Data -> Pack all into .blend.

After doing this you have to re-save the file.

According to the Blender Manual:

Blender has the ability to encapsulate (incorporate) various kinds of data within the blend-file that is normally saved outside of the blend-file. For example, an image texture that is an external image file can be put “inside” the blend-file via File ‣ External Data ‣ Pack into blend-file. When the blend-file is saved, a copy of that image file is put inside the blend-file. The blend-file can then be copied or emailed anywhere, and the image texture moves with it.

Pack

$\endgroup$
  • $\begingroup$ Thank you for this! :D I'm going to send the new file to my friend and if it works, I'll accept your answer, fingers crossed it works on her end :D $\endgroup$ – CraftyMaelyss Feb 5 '17 at 15:16

Not the answer you're looking for? Browse other questions tagged or ask your own question.