0
$\begingroup$

I need to keep the mesh from bending/scaling when I move the bones. What's the best way to do this? I tried the scale modifier for the bone, and that didn't help. I'm fairly new to blender. How do I do this?

EDIT:

Bends enter image description here

$\endgroup$
0
$\begingroup$

This looks like issues with the weighting on the mesh, not any bone constraints, the bones are not changing scale in your images.

You can correct some of the minor bumpy issues by setting weights appropriately, this may require some experimentation to get the correct ones though. To fix this, set the armature modifier to affect the edit mode cage and go into edit mode on the mesh. Select one of the incorrect vertices and view the weights assigned to it in the 'n' panel (this will display the weights of the white, active, vertex). You can play around with these until you get it right. Whe you are satisfied, select the whole edge loop, with the vertex you modified as the active vertex, and use the copy weights on the 'n' panel to update all the weights in the edge loop. Repeat for each edge loop until it looks good. This is a slightly tedious way of doing weighting, but it guarantees accuracy.

The shrinkage at the bend though is a fairly fundamental artefact of the mathematics used to calculate how each vertex is affected by the armature (generally called Linear Blend Skinning). Checking the 'preserve volume' checkbox on the armature modifier tells it to use a different method to calculate this (called Dual Quaternion Skinning), which may give better results.

If there are still problems after trying these two options, look into corrective shape keys (dvd linked an example in the comments - 3.08m into https://www.youtube.com/watch?v=J7ezy20MU6g) or adding additional bones to correct the deformation (this usually requires some experimentation with constraints and weighting to get right).

$\endgroup$
  • $\begingroup$ Thank you, I forgot to check the preserve volume. So the bumps still remain. Let me upload the other views. $\endgroup$ – Ackados Jan 31 '17 at 3:14
  • $\begingroup$ Can only upload two. There is the mesh? $\endgroup$ – Ackados Jan 31 '17 at 3:24
  • $\begingroup$ @Ackados It definately looks like a weighting issue to me. Will add details to my answer $\endgroup$ – Sazerac Jan 31 '17 at 3:55
  • $\begingroup$ Not sure if the edited image will help. $\endgroup$ – Ackados Jan 31 '17 at 4:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.