0
$\begingroup$

I recently downloaded a pack of TIFF mountain brushes for usage in Blender so I could sculpt my own terrain to look more realistic. The brushes can be downloaded here: https://www.youtube.com/watch?v=40glxZCyPeY

I brought one of the TIFF textures in and began using an anchored sculpt brush to place them down onto the subdivided mesh I prepared. However I noticed that the actual brushes were green, unlike a white colour list most brush alphas you'd expect. The brush strength is incredibly weak; even when turned up to 1.000 strength it is very weak and does not make much of a difference (see below). Notice how the texture is green in colour.

enter image description here

I thought I could go to GIMP and edit the images to be white, but when I loaded the TIFF file into GIMP the image is invisible, leaving only the dimensions of the image and nothing else. Perhaps I shouldn't be asking a question like this here but I am stumped. How can I make the images black and white without them turning invisible?

UPDATE: Tried out a method suggested to me. It makes the texture more usable but gives off these ugly rigid shapes on the sides of the mountain that don't look very clean.

enter image description here

$\endgroup$
1
$\begingroup$

You can increase the brush strength past 1.0.

Just click on the slider and type any number between 1 and 10.

enter image description here

$\endgroup$
  • $\begingroup$ Oh gosh it worked, it really worked, thank you!! $\endgroup$ – Emerald Eel Entertainment Jan 29 '17 at 12:53
1
$\begingroup$

The problem is that they are vector displacement maps, not normal black/white displacement maps. Currently, Blender does not support vector displacement maps as sculpting brushes. You can, however, convert them with the compositor to black/white images, and then use them that way.

Normally, doing this would lose some of the functionality of the textures, since vector displacement textures displace the mesh along the mesh normal (the Y component, or the green part of the texture) and perpendicular to the normal (the X and Z components, or the red and blue parts of the texture). However, since these texture are just green, they only displace along the mesh normal and we won't lose anything by converting them to black/white images.

So, to convert them to usable images, open the Compositor, check Use Nodes, and delete the Render Layers node. Add an Image node (Shift + A > Input > Image) and click Open. Navigate to the texture you want to convert and load it in.

In the Render tab of the Properties panel, set the resolution to the resolution of the image you are converting (in this case, 1024x1024), and crank the % up to 100

Now, we need to separate the Green channel from the rest of the image. Add a Separate RGBA node (Shift + A > Converter > Separate RGBA) and plug the Image node into the Separate RGBA node. Connect the G output to the Composite node.

We have now isolated the green channel, but the image is still really dark. To fix that, stick a Math node (Shift + A > Converter > Math) in between the Composite and Separate RGBA nodes. Since the highest value that any of them goes is about 0.35, then set the Math node to Multiply and set the second input to 2.75.

That should be it. Just hit Render and use that as the new sculpt texture. The process can be repeated for the other textures.

enter image description here

Edit: The "stripy" sculpts seen in the edit to the question are caused by color banding. To fix this, just change the Color Depth from 8-bit to 16-bit in the Output panel of the Render settings:

enter image description here

$\endgroup$
  • $\begingroup$ Thank you for the detailed comment. I tried this method out but I am having another issue. See the updated question for the image. $\endgroup$ – Emerald Eel Entertainment Jan 28 '17 at 19:02
  • $\begingroup$ @EmeraldEelEntertainment I just added an edit that will fix that problem. $\endgroup$ – Scott Milner Jan 28 '17 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.