1
$\begingroup$

enter image description here [enter image description here][ enter image description here

I am trying to make some colored glass blocks but on the image below the shadows are render like it's the block is solid.

On the top image, the shadows are rendering fine, but the seethrough makes that weird effect...

Anyone knows the solution (The only change i made was the Ambient Occlusion effect)

*(I Also render it on blender render)

$\endgroup$
  • $\begingroup$ Step 1: switch to Cycles. Blender Render is going down, and I am guessing it will be deprecated in a few years. $\endgroup$ – JakeD Jan 28 '17 at 12:13
  • 1
    $\begingroup$ But cycles is soo heavy, it takes 6h to render a simple thing like this, i have Geforce 1070 and i-7 and still takes soo long $\endgroup$ – ioliano Jan 28 '17 at 12:27
  • $\begingroup$ Then you're doing something wrong with Cycles...hardly anyone uses BI anymore, and if you want your work to be worth much in a few years, I'd highly suggest switching to Cycles. Of course, that's just my opinion; use whatever you want ;-) $\endgroup$ – JakeD Jan 28 '17 at 12:44
  • 2
    $\begingroup$ Here, you should get answer on all supported features, and Blender Render is still one. Anyway..it should work, I just tried: you should have transparency switched off... if you can share the file (eg: using blend-exchange.giantcowfilms.com) we can take a look at what's not working. Otherwise show transparency settings for those glass objects. $\endgroup$ – m.ardito Jan 28 '17 at 13:36
  • $\begingroup$ If I recall correctly you have to enable something like Receive Transparent or similar in the shadow receiving object (not the glass ones) so that transparent shadows are cast $\endgroup$ – Duarte Farrajota Ramos Jan 29 '17 at 1:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.