How to delete unwanted material and texture used in my scene?

I have an interior scene and when I press shift+Z it renders in a good way, but when I press F12 a small render shows up and it's stuck there. I thought of removing the extra material and texture used. Some are assigned and some are not assigned.

I want to delete all the material and texture which are not in use. I have used the Orphan addon, but did not see any success. Is there any other addon or a quick way to delete them?

gif showing the problem

  • 3
    $\begingroup$ afaik, by default, unused "orphan" data is not saved... try saving the file, load a new standard file (or close/reopen blender) then reload your saved file: it should be gone. Unless you explicitly said blender to "save this datablock even if it has no users", toggling the "F" little button aside datablocks... that toggle adds/removes a "ghost" user for the datablock. Can't propery understand the relationship with rendering issues... start removing fomr the object materials you don't need... your cube has at least 5 materials enabled on it... $\endgroup$
    – m.ardito
    Commented Jan 28, 2017 at 12:39
  • $\begingroup$ Related - blender.stackexchange.com/questions/27190/… (only for deleting materials). $\endgroup$
    – Mr Zak
    Commented Mar 10, 2017 at 21:42

3 Answers 3


In Blender Version 2.79b go to "Blender File" in the Outliner. Find the material you want to remove and right click it. An option to delete it will be presented to you.

Be warned that this will permanently delete the material with no undo.

Outliner > Blender File > materials > "a material" right click delete

  • 1
    $\begingroup$ This may crash blender if you delete a material that is still used by some objects $\endgroup$
    – Samie Bee
    Commented May 3, 2018 at 23:06

I just found it out. I thought I will not be able to delete it. So here it is! I hope it help, Goodluck!


If you want to delete material or texture slots, then you select it and then press the minus sign to the right of the materials, that should remove the material from the object. The actual material data won't actually be gone until you save and reopen the blend file, but other than that it should work.

  • $\begingroup$ i have more than 200 objects i dont want do it manually can i select all and then make it $\endgroup$
    – atek
    Commented Jan 29, 2017 at 3:33
  • $\begingroup$ There's an add on (User Preferences > Add Ons > Material Utils). Check the box, and then select all your objects that you want to remove materials from, then press Shift-Q, which will bring up the Material Utils menu. Select Replace Material, and then, replace the materials that you don't want with other materials. I'm not sure if it will work, but hope it helps. $\endgroup$
    – Gecko_Lord
    Commented Jan 29, 2017 at 22:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .