1
$\begingroup$

I keep getting a visual C++ runtime error while starting up a fresh install of blender.... The following is a list of tasks that I have performed to try and fix the problem.

  • Uninstalling and Reinstalling Python 2.7.5
  • Uninstalling and Reinstalling Current Versions of C++
  • Used a working computer to compare versions of C++ and installed parallel versions of C++ clearing out my current list and using the working computer's versions and distributions (which were very hard to find considering on microsoft's website C++ 2008 only has one version available for download now)

Although version 2.63 works fine for me, I have just recently purchased an Addon that I would like to use for blender/Second Life called "Avastar" I can only use beta versions of this software with 2.63 as the stable version is only compatible with 2.69

After about 2-3 hours of installing and uninstalling software related to C++ and Python I've done a system restore and am now posting for help. Below are my current System Specs

  • AMD Phenom II X4 965 (3.40 GHz)
  • NVIDIA GeForce GTX 550 Ti
  • 8GB DDR3
  • Windows 7 x64 Ultimate

Please note: I've tried installing both versions of blender (x64, x86) both Zip & Installer

Programs and Features

$\endgroup$
  • $\begingroup$ doesn't blender come with Python 3? $\endgroup$ – WorldSEnder Feb 22 '14 at 22:24
  • $\begingroup$ Thanks so much for this comment... I uninstalled Python 2.5.3 and it worked perfectly. $\endgroup$ – user1678317 Feb 24 '14 at 17:29
  • $\begingroup$ @WorldSEnder Feel free to add your comment as an answer :) $\endgroup$ – gandalf3 Mar 1 '14 at 0:58
1
$\begingroup$

Blender 2.69 uses and comes with Python 3 meaning that there is no necessity to install Python 2.7.5 or any other version at all. Due to the changed syntax, etc. you'll most likely run into syntax errors or non-executable code.

$\endgroup$
0
$\begingroup$

You need Microsoft Net Framework 4 to run blender. Download it from here. Also note that you do not need to install python to use blender. Blender comes bundled with python 3.3.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.