I've modeled with guy this week and I wanted to rig it, but I got this error. I've tried all the fixes I've founded (remove doubles, deleted constraints, delete modifier, add and apply decimate modifier, etc.).

Here is the blend file:

  • 1
    $\begingroup$ No blend file provided $\endgroup$ – Tak Jan 25 '17 at 13:09
  • $\begingroup$ blend-exchange.giantcowfilms.com/b/2613 $\endgroup$ – Magical Paladin Jan 25 '17 at 13:40
  • $\begingroup$ @Tak It is preferably to advise a new user how to upload blend files if a blend is required. $\endgroup$ – Ray Mairlot Jan 25 '17 at 13:44
  • $\begingroup$ @RayMairlot sorry, I updated the question myself, but will do this next time, no worries :) $\endgroup$ – Tak Jan 25 '17 at 13:45
  • $\begingroup$ @MagicalPaladin the .blend file doesn't have any armatures just mesh $\endgroup$ – Tak Jan 25 '17 at 13:48

So I separated all objects and parented each one by one and it seems that the belt and torso are the issue. I tried to recalculate the normals and Remove doubles, but it seems that there is something wrong with the two. Maybe try Retopo-ing the the two. Also for whatever reason there is no weight appearing in the weight paint mode which brings me to the conclusion that you will have to manually weight paint the model after fixing the two objects of course.

Additionally I looked up the issue and found a concise list of the stuff you need to check in your model on a reddit forum Here it is:

Anything that has lots of intersecting meshes seems to bork the auto weightpainting. If you separate loose parts, weight all the parts, and then join them, you can get an approximate weight painting. Other things worth checking -Are the rig and mesh aligned on the axis properly? -Have you applied scale and rotation on everything you're weighting? -Did you make sure to keep the x - axis mirror option on when rigging? The weight painting gets wonky when things are less symmetrical. -Have you removed double vertices, checked your mesh for bits that don't aren't connected, and recalculated normals? -Is your mesh or armature too large? Sometimes scaling it down can help. That error message is frustrating because it gives very few clues as to what you're doing wrong.

Here is the file:

  • $\begingroup$ Your Welcome Bro $\endgroup$ – Grimlock Jan 31 '17 at 9:03

I do not know why (I think it's just Blender's Automatic Weighting Algorithm), but it worked when I added a subsurface modifier then did Ctrl+P and then With Automatic Wieghts. After that, I removed the Subsurface modifier and it was all fine.

Hope this helps

  • $\begingroup$ Will try it and tell if it's works $\endgroup$ – Magical Paladin Jan 26 '17 at 20:42
  • $\begingroup$ Just tried it, not working, could you please share your file and tell me which blender version you use ? $\endgroup$ – Magical Paladin Jan 26 '17 at 20:48
  • $\begingroup$ I use Blender 2.78a and here I've tried it multiple times with the file you provided. Make sure you don't Apply the modifier. $\endgroup$ – Grimlock Jan 27 '17 at 6:33
  • $\begingroup$ Never mind, when I do that Blender doesn't give the error message, but doesn't add the wights. $\endgroup$ – Grimlock Jan 27 '17 at 6:35

Alternatively you could use the Mesh Deform method to rig your character:

First create a lowpoly model of the character and make sure the lowpoly is around the highpoly.

Then go to the original mesh and add a Mesh Deform modifier. Set the lowpoly mesh as the object in the object box and then parent the lowpoly to the armature.

NOTE: Make sure that you DO NOT parent the original mesh to the armature. Also make sure the low poly model has a black shader attached to volume instead of surface.

Blend File: https://drive.google.com/drive/folders/0B6P9xP7owZILY2ZKUk1pQTNfQUk?usp=sharing

  • $\begingroup$ Hope this helps $\endgroup$ – Grimlock Jan 27 '17 at 9:10
  • $\begingroup$ Update: Extended the "NOTE". $\endgroup$ – Grimlock Jan 27 '17 at 10:05
  • $\begingroup$ Tell me if it works $\endgroup$ – Grimlock Jan 27 '17 at 11:08
  • $\begingroup$ Added blend file $\endgroup$ – Grimlock Jan 27 '17 at 11:15
  • $\begingroup$ works i just need to correct weight $\endgroup$ – Magical Paladin Jan 29 '17 at 11:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.