0
$\begingroup$

When you create chain, Blender add path called deform and rot_link which is empty.

I have extruded the vertices of deform path to make more links in the chain.

Now the problem is when is scale down the chain. Scaling down deform path, links are disapearing.

How to scale/manipulate the chain after you create it ?

EDIT: Make a chain, extrude deform a couple of times and scale down the chain, deform and rot link.

enter image description here

EDIT: I have scaled down chain in edit mode. Is it possible to scale deform path so that it fits the length of the chain? You can see how path is way to bigger than chain itself. enter image description here

$\endgroup$
  • $\begingroup$ I can't get the setup you describe, perhaps at least an image, and/or better description would help... $\endgroup$ – m.ardito Jan 22 '17 at 22:09
  • $\begingroup$ It's the same as I described. When you scale down scale down the chain, deform and rot link, created links are disappearing. $\endgroup$ – Wildfire Jan 22 '17 at 22:22
  • $\begingroup$ sorry, maybe it's me but "When you create chain, Blender add path called deform and rot_link which is empty" really means nothing... did you use an addon for chain generation? afaik blender ha no mean to "add" those objects (a path and an empty, it seems) on its own.. $\endgroup$ – m.ardito Jan 22 '17 at 22:39
  • $\begingroup$ Yes, it's chain addon. Go to user preferences and install add chain. Add chain is in create tab. This addon creates chain, deform (path) and rotlink (empty). $\endgroup$ – Wildfire Jan 22 '17 at 22:45
1
$\begingroup$

To scale the links of the chain, you have the chain object selected and go into Edit mode. The links disappearing is a desired behavior, as the links are trying to fit the length of the deform curve.

$\endgroup$
  • $\begingroup$ Thanks, it seams this is the case. Is it possible to scale deform so that it fits the length of the chain? I've updated main post. $\endgroup$ – Wildfire Jan 23 '17 at 9:02
  • $\begingroup$ Did you scale the chain down in edit mode? If you did, the chain would have automatically adjusted to fit the length of deform. Its not set up to go the other way. If you didn't do it in edit mode, you can press ctrl+A and apply the scale of the chain. $\endgroup$ – cmomoney Jan 23 '17 at 9:36
  • $\begingroup$ Yes, I scaled it in edit mode. But when I went in object mode chain didn't fit the length of deform path. Deform path was lengthier than chain. $\endgroup$ – Wildfire Jan 23 '17 at 12:14
  • $\begingroup$ You might need to start over. The way the addon works, the chain will always fit the length of the curve. $\endgroup$ – cmomoney Jan 23 '17 at 14:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.