0
$\begingroup$

I have a single object that i have separated into many objects due to sizing issues (level of detail/triangles bla bla) and since separating them there are now seams between each new object in blender.

here are some examples:

enter image description here

enter image description here https://gyazo.com/10a8c9008a8419b6499ac17f865e06d9 https://gyazo.com/ed704c4f3d8463b0fb7c1d476940c507

How do I get rid of these. I know it's do-able, however I have not done it in, many a year.

Cheers

$\endgroup$
3
  • 2
    $\begingroup$ It's due to normals: separated objects have their own and they can't be "aligned" with other objects, even if you make them absolutely adjacent or overlapped. I can't understand the need to split an object due to its levels/triangles (splitting objects gives more geometry, not less), but imho that is the cause. $\endgroup$ – m.ardito Jan 19 '17 at 12:32
  • $\begingroup$ see this question/answers also (there was another one I saw, can't find it now, though): blender.stackexchange.com/questions/67629/… $\endgroup$ – m.ardito Jan 19 '17 at 13:21
  • $\begingroup$ Hey there, I needed to separate the object as it is being imported into SL and it had too many triangles and too many face per material or, whatever lol I can't remember how they worded it. So I have the object split into left arm, right arm, torso, legs etc... I don't understand how to apply the solution in that link to my project as the open ends of the now split object isn't flat and to creat a face on the ends to cap it off would cause clipping $\endgroup$ – Andrea Jan 20 '17 at 0:23
1
$\begingroup$

As someone mentioned in the comments, this is caused by how normals are calculated for each mesh you split off. The normals at the vertices along the edge of your split meshes are now pointing in slightly different directions. To fix this, transfer the normals from your original un-split mesh to the parts you split it into. You can do this using the Data Transfer modifier.

Comprehensive steps to fix:

  1. Create a copy of your original un-split mesh and place in the scene. You can hide this mesh.
  2. Split your original mesh into the pieces you want.
  3. Add the DataTransfer modifier to the split pieces with the following settings
    • Source object - this should be set to your original un-split mesh copy
    • See screenshot for other settings

data transfer settings

$\endgroup$
0
$\begingroup$

I have had the same problem, if tried going into the wire mainframe and deleting the conjoined messy parts ect, i guess helps or optimization as well. However, the main reason it was bugging me when when I go to paint, the seams are all messy, however I found a solution for this.

In the UV editor section when painting, in your UV section to paint on, find the part with the seam, and paint and clean up the seam from the UV editor. I have made my seams almost impossible to recognize with a little bit of blending and art.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.