6
$\begingroup$

So in the image below there are two circles, how can I remove the internal vertices between them without messing up the outside shape. I'm working on a gun and this is just a simple way to illustrate the issue I'm dealing with. If I where to go in and delete the internal faces it would leave holes on the outside of the object, is there a fast way to get around this?

Red area shows internal geometry

$\endgroup$
8
$\begingroup$

Assuming that you are using a release of Blender that is at least 2.77 or newer, then you can use the edit mode boolean tools and save a couple steps.

  • First select one element of the object in edit mode by linked geometry by selecting a face, edge, or vertex, and then press L with your mouse hovering over it.

  • Press Spacebar and type Boolean and select Mesh: Intersect (Boolean) from the menu, or press Enter when the option appears in the menu.

  • Next, press F6 to bring up the options for the tool (or go to the operator panel in the toolshelf) and change the mode to union.

enter image description here

$\endgroup$
  • 1
    $\begingroup$ what if I have 100 cubes joined as one object having overlapping parts? When I switch to edit mode and select all then hit space and choose Intersect Bool then union I get the message "No intersection found", but it works if I select one of the cubes using L then boolean it with the intersected one. Because I have many objects joined as one object, Is there a way to do it without having to select the faces of each cube then running the boolean operation? $\endgroup$ – Tak May 30 '17 at 4:13
  • $\begingroup$ @Tak with that many objects it may be easiest to separate them a bit (P>selection) and rejoin them with fewer elements at a time. You could try using the swap option in the operator panel after some booleans if there are missing faces, as it can get a bit messy and may need some manual cleanup with too many objects. $\endgroup$ – Timaroberts May 30 '17 at 4:58
  • $\begingroup$ dropbox.com/s/klpedtksyq1en4q/… try this please, once you open the file, switch to edit mode then space and choose intersect boolean and Union, I don't know why for some reason once I do Union bool the whole pose before the selected one gets deleted? $\endgroup$ – Tak May 30 '17 at 6:22
  • $\begingroup$ Could you please advice whenever you can? $\endgroup$ – Tak May 30 '17 at 12:19
5
$\begingroup$

You can use the boolean modifier. In order to use it, you first have to seperate the spheres into seperate objects. Go into edit mode, select everything with A, press P and click By loose parts.

enter image description here

You now have 2 seperate spheres. Go back to object mode, select one of the objects and add a boolean modifier.

enter image description here

Select the other object under the object drop-down menu and change operation to union.

enter image description here

Do the same thing for the other sphere.

Now you will have two objects, one for the two spheres combined and one for just one as shown below:

enter image description here enter image description here

Select the object which has both spheres and Apply the modifier by clicking on Apply.

enter image description here

Now delete the other object of just one sphere by selecting it, and press Delete.

And will now have an object with the shape of both spheres combined, but without the interior geometry as shown below:

enter image description here

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.