6
$\begingroup$

this is driving me crazy. I want the trails in this scene to glow:

nodes problem

But when plugging the trails into the z combine node the blur is removed. If you have an idea why that is and what I can do to fix it I would be much obliged.

Many Thanks for your answers! Here is what happened:

Not using Alpha results in this:

alpha with nodes

The blur is there but it is behind the geometry.

I already tried blurring the Z pass before and it turned out like this:

enter image description here

The Map Range nodes are necessary because otherwise the Z blur would just turn out white. There is some blur visible but the rest is messed up.

I think the problem is that the blurred render layer is wrapped by the unblurred render layer. This is what Gandalfs example would look like when putting a cube in front and one behind the blurred one:

enter image description here

$\endgroup$
  • $\begingroup$ Try disabling Use Alpha. $\endgroup$ – gandalf3 Feb 19 '14 at 10:00
2
$\begingroup$

Either disable Use Alpha or blur the Z as well:

enter image description here


Update

As pointer out by the OP, the above solution does not work when there is geometry behind the glowing object.

Here are some alternative methods roughly in order of number of steps needed to set up:

1. ID Mask:

This method is probably the quickest as it doesn't even require more than one renderlayer.

  1. Enable the Object Index pass in Properties > Renderlayers > Passes:

    enter image description here

  2. Select the object(s) you want to blur and set the Pass Index to a unique number so that no other objects have the same Pass Index.

    enter image description here

  3. In the compositor, add an ID Mask node and set the Index to the same number you set the objects:

    enter image description here

Also see this related question.

2. Z-Mask:

You'll notice that in method one that the glow appears in front of other objects:

enter image description here

You may want this effect or you may not. If you don't, then you can use the Zmask in Properties > Renderlayers > Layer:

  • Background objects are on Layer 1
  • Foreground objects are on layer 2
  • Glow objects are on layer 3

enter image description here

$\endgroup$
  • $\begingroup$ Thanks for trying it out. What makes your example different: There is no geometry behind the blurred cube. See the screenshot I added to my question. $\endgroup$ – Christian Feb 19 '14 at 15:20
  • $\begingroup$ @gandalf3 thank you so much for posting this answer. I'd never have solved a similar issue I was having with out it. blender.stackexchange.com/q/97048/44673 $\endgroup$ – chris loughnane Dec 23 '17 at 1:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.