When I export / Save As Game Engine Runtime, I do not get an exe file. I made a file on my desktop, named it 'runtime001'. These are the only exe files and they don't do anything.

enter image description here

enter image description here

  • 1
    $\begingroup$ You appear to be on a Linux based system, Linux doesn't have "Executables" and as far as I know can't open EXE files, unless there is some sort of emulator-like software like Wine $\endgroup$ Jan 18, 2017 at 18:21
  • $\begingroup$ So, I can transfer everything Blender to a flash drive, open/install on Windows, and then everything should work? $\endgroup$ Jan 18, 2017 at 19:10
  • $\begingroup$ I have no clue, try it yourself. Some times you have to manually copy some DLL files from Blender installation dirctory into the game engine runtime export folder, but those will be unavailable in Linux, obviously. $\endgroup$ Jan 18, 2017 at 19:15
  • $\begingroup$ Well, that worked okay. My only problem is the game produces only a gray screen. I'll write a new question for that, (after checking past questions.) @Duarte You should get credit for answering this. You want to post it as an answer? $\endgroup$ Jan 18, 2017 at 22:07
  • $\begingroup$ Not really sure what the problem was really, or what part of my comments helped solve the problem. Truth is non of it actually constitutes a full featured answer worthy of posting, but thanks for the concern. $\endgroup$ Jan 19, 2017 at 3:04

1 Answer 1


Which exporter addon did you use? If you used the 'save game as runtime' it creates an executable for the platform you are on. This is found in the File->Export->Save Game as Runtime

If you use the 'Game Engine Publishing', you also need to download blender for the different OS's, and point the addon at the filepath for blender. This is a fair bit more complex, and the options are found in the Render Panel.

I'm going to assume you're using the 'save game as runtime' If you are running windows, it will create an exe, if you are on linux it will create a linux executable - which does not have a file extension. In a quick test I did, exporting it from my system worked find, although it took several seconds.

One thing to check is that there is a located blenderplayer file. When you chose 'save game as runtime,' you see this on the left:
enter image description here
Check that there is a file at the location in the circled box.

Also check what folder you're exporting it too. Neither of the folders shown in the question have the exported executable.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .