1
$\begingroup$

EDIT: I Figured it out! I just hollowed out part of the mesh, on the side that would touch the mirrored object.

Hopefully this can help others having the same problem.

Dunno how that worked, but it did.


Original post:

Whenever I try to mirror an object, the mirrored object is always lightor or darker than the original.

For example... Example

Is there a way to fix this? Originally I was using this mirror method to create a lightbar (below):

Lightbar

But as you can see, one side of the triangular bit is CLEARLY different from the other in terms of shading..

However this only seems to be the case on smooth shading, flat shading looks just fine.

However, when I export it, to be used in a game, it reverts to smooth shading and looks awful.

$\endgroup$
  • $\begingroup$ I am using Blender 2.7.3.0 btw, because I probably should've mentioned that. $\endgroup$ – BlenderNooblet Jan 18 '17 at 17:38
  • $\begingroup$ Those are generally cause by inconsistent normals. Make sure your geometry center is perfectly aligned with the desired mirror axis, make sure the seam vertex are correctly aligned at the origin axis. Turn on merging and clipping and check if the tolerance is high enough. $\endgroup$ – Duarte Farrajota Ramos Jan 18 '17 at 18:27
  • $\begingroup$ I don't think that it is normals as I have recalculated normals multiple times... and wouldn't the normals for a simple cube already be correct? Like, in the first picture, that is a newly created cube, and it has the same problem. I'll add my normals to the main topic. Well, apparently I can't due to rep restrictions, but they all seem to look normal. $\endgroup$ – BlenderNooblet Jan 18 '17 at 18:54
  • $\begingroup$ link Maybe this will work, here are normals. imgur.com/a/fBXOr Also here are my origins.. imgur.com/r4TCirX I don't 100% understand what you are saying about getting the geometry center perfectly aligned with the desired mirror axis... Or the seam vertex... Could you please explain? $\endgroup$ – BlenderNooblet Jan 18 '17 at 19:00
  • $\begingroup$ Fixed it ! Just did this : imgur.com/a/7PIHf Thanks for the help though! $\endgroup$ – BlenderNooblet Jan 18 '17 at 19:14
0
$\begingroup$

Figured it out! I just hollowed out part of the mesh, on the side that would touch the mirrored object.

And basically just went, delete / faces on that part.

Hopefully this can help others having the same problem. Here is an image showing what I mean.

http://imgur.com/a/7PIHf

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.