1
$\begingroup$

i was just familiarizing myself with the new Bendy Bones to plan a rig when i ran into this problem. ...gif below. it's unlikely that i caused it, cuz what you see is a really simple setup and the problem persisted every time i recreated the setup: add a bendy bone, add a mesh, weight. it's disappointing - i could really use that property.

edit: what i mean is that it's not affecting the mesh like Curve XY Offsets or Scale :]

however, you can see on this youtube video: https://www.youtube.com/watch?v=nQCo2AGRT6o, it actually works as it's supposed to. he's using 2.77.1 and i'm using 2.78.

enter image description here

$\endgroup$
  • $\begingroup$ It looks like the easing property is working to me. What aspect of easing isn't working? $\endgroup$ – Mike Belanger Jan 18 '17 at 13:58
  • $\begingroup$ Oooh I see Easing isn't deforming the mesh, unlike the other settings. $\endgroup$ – Mike Belanger Jan 18 '17 at 14:00
  • $\begingroup$ well, in the gif, you see Easing affecting the bone. that's it...it ONLY affects the bone. it doesn't affect the mesh like Curve XY Offsets or Scale. but on this youtube video: youtube.com/watch?v=nQCo2AGRT6o, you can see it actually working. he's using 2.77.1 and i'm using 2.78. thanks! :] $\endgroup$ – Zac Jan 18 '17 at 14:03
  • $\begingroup$ Looks like a bug to me. Maybe a dev can confirm. $\endgroup$ – Mike Belanger Jan 18 '17 at 14:15
2
$\begingroup$

Well it kind of works, as you can see in this Blend File here:

I say kind of because the limitation is that you have to set up the driver which he's using in the video. Looks like a dependency graph issue to me to be honest. This theory is backed up by two things:

  • if you transform the controller bone, and cancel that transform using Esc the bendy bone does not jump back into its original state (that's a bad bad thing)
  • if you run Blender from the command line using the --enable-new-depsgraph switch, everything works totally fine, even not having drivers on the bone deforms the mesh as it should.

You could try having the controller bone in a separate armature object. That might help overcoming the dependency graph issue. Or simply run Blender with new depsgraph on as indicated before.

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.