5
$\begingroup$

I'm having an issue filling a cube with objects using a ParticleSystem. It's as if a diagonal plane has cut through the cube and eliminated particles. This doesn't happen to the front plane of particles though, which can make it difficult to tell that it's happened from that view.

I only added the UV Spheres to help visualize the problem. They don't have any affect on the missing particles. Cube of spheres

I've tried many setting, including, but not limited to; Changing the particle size, Cube Scale, Resolution, etc...
I also tried double clicking Hexagonal Grid (I heard that will sometimes set things straight).

Thanks for any help.

$\endgroup$
  • $\begingroup$ could you please share your blend file $\endgroup$ – Nils Eisen Jan 18 '17 at 3:21
  • 1
    $\begingroup$ This issue should be fixed in the latest version of Blender (2.78b). $\endgroup$ – Shrill Feb 9 '17 at 19:30
4
$\begingroup$

One way to solve this is to bevel each vertex of the cube very little. Tab into edit mode. A to select all vertices. Press Ctrl+V and select "Bevel". Then give it a very small amount of Bevel Offset (I used 0.001 here). Then Tab out of edit mode and it'll work.

Bevel

Another simpler way to do it is to select all the faces and hit Ctrl+T to triangulate the faces.

Triangulate

$\endgroup$
  • $\begingroup$ Thanks @Kidus, I tried your method and it was a successful workaround for my problem. I also tried a few other bevel offset amounts, with varying degrees of success. I'll wait a bit before I give you an 'answered', just to see if anyone else can figure out why this happens. $\endgroup$ – TinySharks Jan 19 '17 at 5:06
  • 2
    $\begingroup$ Ok, I tried both methods @Kidus. They will both fill the cube properly, with a few caveats. When using the bevel method, the resolution must be an odd number, otherwise, the center row will be missing. When using the triangulate method, the resolution must be 11. Any other number leaves seemingly random rows out. $\endgroup$ – TinySharks Jan 20 '17 at 1:06
1
$\begingroup$

I have investigated this a bit further, and it appears to be a bug (which is still present in Blender 2.78c) :

Using an added Cube in combination with Particles > Volume > Grid results in missing particles.

Strangely, there is no issue when you use the original Cube "Cube", or a duplicate (Shift + d) of the original Cube. ??

So an appropriate "easy" solution, until this issue is resolved; would be to use the standard default cube when you use Particles > Volume > Grid

Particle > Volume > Grid bug

Blend file illustrating the issue

Note: (I moved your added cube: "Cube.001" to Layer 20, and the default cube "Cube" to Layer 1)

$\endgroup$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.