0
$\begingroup$

I have a wood texture such as this one.

enter image description here

If I UV map it to a plane of the same aspect ratio, the spacing between the wood seams will be well preserved, and I can see the same patterns.

However, when I UV map it to a twisted, arbitrary surface, the vertical seams become so dense that no other texture (such as the circular ones) is visible.

enter image description here

How do I have a little control over the UV mapping such that the original pattern is still visible across my surface?

$\endgroup$
1
$\begingroup$

There are two ways:

1) classic; in edit mode select all vertices UV mapped, then open an UV image editor, select the wood texture, select all the UV grid and press S to scale it at the desired size.

2) If you don't want to modify the UV mapping, in the node material editor add an input UV node, plug it into a mapping node, and plug the latter in the vector input of the image texture node, then adjust the scale values.

$\endgroup$
  • $\begingroup$ Beautiful solution. I went with option 2 and got this: imgur.com/a/hPLYH. Absolutely amazing. May I double check with you, if I also have albedo map, selection map, etc. in my material node tree, I should feed the same mapping node to them as well right? I think this would generate the same scale for albedo, diffuse maps, and etc. Here is my node setup: imgur.com/a/royzm. $\endgroup$ – Sibbs Gambling Jan 17 '17 at 15:15
  • 1
    $\begingroup$ Yes, it's right! $\endgroup$ – josh sanfelici Jan 17 '17 at 17:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.