0
$\begingroup$

I am an amateur rigger at best. I do not have much of a grasp on the technical side of it, so this probably seems very stupid.

My rig is putting a "knot" in my mesh and will only work if the IK is flipped completely away from the pole target. One of my feet is also askew and I don't understand why. The mesh and rig are perfectly mirrored (or so i thought.)

I'm really not sure how I screwed up, I would really appreciate some advice.

This post seemed to have the same problem IK + Pole Target {Rig} is =//= Twisting my Characters Mesh but I don't understand their solution. I tried changing the IK solving to iTaSC but that didn't help.

The arm bends in the exact opposite direction that it should be bending.

When I rotate the pole angle so the rig works correctly, the mesh deforms and twists into a knot. Knot in the arm

Here is my .blend

$\endgroup$
  • $\begingroup$ By perfectly mirrored do you mean renaming the bones? $\endgroup$ – user32399 Jan 16 '17 at 21:07
  • $\begingroup$ bones are mirrored. As well as the names. Re-set the rotation and placement of the bones and you will see that. Or just go into edit mode. The picture is just to show the problem. $\endgroup$ – Uglyfire Jan 16 '17 at 21:11
  • $\begingroup$ @Uglyfire could you please explain with screenshots what is the exact problem? $\endgroup$ – Tak Jan 17 '17 at 0:27
  • $\begingroup$ It only lets me post two links at once, so I'll get a better picture. $\endgroup$ – Uglyfire Jan 17 '17 at 16:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.