1
$\begingroup$

This question already has an answer here:

As I navigate around my growing scene parts of my models disappear. Is this a settings issue or is it because my computer doesn't have enough power?

enter image description here

$\endgroup$

marked as duplicate by Denis, cegaton, David Jan 12 '17 at 17:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2
$\begingroup$

It's the camera clip plane. It controls the closest and furthest distance that gets rendered. You can adjust it for the editing view in the properties region (N key):

Clip plane for the editor view

...and for any render cameras in the camera settings panel:

Clip plane in the camera settings

It is a good idea to scale both the near and far clip plane by the same factor (i.e. scale 1cm..100m up to 1m..10km) to preserve the precision of the depth buffer.

Technical: when objects are drawn, each pixel's distance to the camera is recorded in a "depth buffer". If another object draws to the same pixel, the depth buffer is consulted to know whether to draw over the pixel (new pixel is closer and in front of old pixel) or skip the pixel (new pixel is further away).

The precision of the distance values recorded in the depth buffer is limited, thus there is a nearest possible value (near clip plane) and a farthest possible value (far clip plane). Everything outside that range is simply not rendered. If the depth buffer is stretched out too far (i.e. to 1mm..100km) depth accuracy suffers and "Z-fighting" ensues (pixels that are farther away randomly draw on top of nearer pixels due to rounding errors).

$\endgroup$
0
$\begingroup$

It is a setting issue. If you go up to the camera options and increase the range you should be able to see everything.

$\endgroup$

Not the answer you're looking for? Browse other questions tagged or ask your own question.