0
$\begingroup$

enter image description here Hi everyone , I am having trouble parenting my armature to my actual character mesh. I select the mesh, shift right click on any bone in the armature and hit Ctrl P and add with automatic weights. My whole mesh is mirrored and only stretches and deforms on the mirrored side Hand but everything else is completely fine and functional. Any help would be appreciated thanks.

Blend:

$\endgroup$
  • $\begingroup$ do you still have the mirror modifier on the mesh? Because the rig will not work with a mirror modifier. $\endgroup$ – David Jan 12 '17 at 2:28
  • $\begingroup$ could you provide your .blend file to be able to help you? $\endgroup$ – Tak Jan 12 '17 at 2:50
  • $\begingroup$ Yes I did. I deleted it then added the parent and added another mirror modifier and it had a better effect but I still have clipping and merge enabled and the mesh divides in half when I move the character around. But the hand was normal again. $\endgroup$ – user34518 Jan 12 '17 at 3:01
  • $\begingroup$ How would I be able to do that Tak? $\endgroup$ – user34518 Jan 12 '17 at 3:01
  • $\begingroup$ I also tried to delete the mirror, Shift D to copy my one side then S key then X key -1 to scale it across the X axis evenly and it still had the messed up finger effect to it $\endgroup$ – user34518 Jan 12 '17 at 3:12
0
$\begingroup$

The problem is that your rest pose is different from your pose position. To fix this:

  1. Switch to Pose Mode
  2. Select all Bones with A
  3. Hit Space bar
  4. Select Apply Pose as Rest Pose
  5. Switch to object Mode
  6. Select Your mesh first then select the armature using Shift+Right Mouse Click
  7. Hit Ctrl+P then choose Automatic Weighting and this will fix your problem as shown below

enter image description here

$\endgroup$
  • $\begingroup$ Thanks Tak. Was your mesh fully functional after? $\endgroup$ – user34518 Jan 12 '17 at 17:15
  • $\begingroup$ Yes it was. If you faced any other problem as you said after changing some settings then could you ask another question and provide your updated .blend file and send me a link of your new question here? $\endgroup$ – Tak Jan 12 '17 at 22:27
  • $\begingroup$ Here it is blender.stackexchange.com/q/71206/34518 $\endgroup$ – user34518 Jan 12 '17 at 22:30
  • $\begingroup$ sorry I forgot to @ you $\endgroup$ – user34518 Jan 12 '17 at 22:37
  • $\begingroup$ @user34518 no worries, I've provided an answer for your problem $\endgroup$ – Tak Jan 12 '17 at 23:15

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.