1
$\begingroup$

I am new to blender and have created a 3D model of a spaceship using version 2.78 in cycles. This ship has textures using pics, which have been unwrapped, and also using materials such as emissions, diffuse, etc. When I render all looks awesome. When I export all textures and materials are not present (mtl file is present), there is just a grey 3d model. Yes I can reapply the texture but not the emission, diffuse etc materials. I can't bake it for export as I get an error "no active material found". How can I get my 3d model with all textures and materials exported. I have options for .obj format. This is the format accepted by the compositing program I am using; hitfilm.

$\endgroup$
  • $\begingroup$ Anyone with thoughts on this? I am sure I am not the only person with this concern. $\endgroup$ – RsutyCat Jan 15 '17 at 13:10
  • $\begingroup$ You will have to bake a cycles material to an image that can be used in other programs. You have to add an image texture node to the material with the target image and the node has to be selected when you bake, you don't connect it to any other node, it just has to be there to define the target image. $\endgroup$ – sambler Jan 15 '17 at 16:52
  • $\begingroup$ Tried it out and it won't work on my 3d model of the spaceship. Checked things on and off on the export menu for obj but still nothing. So, i tried creating a whole new object and material bake that one. It worked like a charm. Question now is what would prevent the process from working my 3d spaceship i created? I know i am capable of doing it but just can't get this one model to export with all materials and textures. The model has two textures and 12 materials. $\endgroup$ – RsutyCat Jan 22 '17 at 12:37
  • $\begingroup$ You will need to add an image node to each material, they can all use the same image, if you are trying to bake it onto one image. $\endgroup$ – sambler Jan 22 '17 at 19:37
  • $\begingroup$ Yes i have done this as layed out. It works when i create a new 3d model from scratch and add two textures and two materials. The nodes added to each material (not attached to anything) bake just fine and the model exports as expected. The concern I am having is when I do it to my other 3d model (the spaceship) i created a few months back and add the nodes for the material to bake to (not attached to anything) it won't bake. What would prevent this from working on my spaceship but just fine on my other model? Is there something else I need to look out for? Video links? $\endgroup$ – RsutyCat Jan 25 '17 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.